HDU-1387 Team Queue

题目:

Team Queue
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1862 Accepted Submission(s): 630


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.



Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.



Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.


Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0



Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
// oj.cpp : 定义控制台应用程序的入口点。
//

#include <iostream>
#include <algorithm>
#include <sstream>
#include <string>
#include <numeric>
#include <cstring>
#include <map>
#include <set>
#include <utility>
#include <map>
#include <list>
#include <queue>
#include <functional>
#include <bitset>
#include <stack>

using namespace std;

int toTeam[1000005];

int main()
{
ios::sync_with_stdio(false);
cin.tie(NULL);

int N;
int cnt = 1;
while (cin >> N &&N)
{
cout << "Scenario #" << cnt++ << endl;

vector<queue<int>> Q(N);
queue<int> teamQ;

for (int i = 0;i < N;++i)
{
int n;
cin >> n;
for (int j = 0;j < n;++j)
{
int a;
cin >> a;
toTeam[a] = i;
}
}

string L;
while (cin >> L&&L != "STOP")
{
if (L == "ENQUEUE")
{
int a;
cin >> a;
int team = toTeam[a];

if (Q[team].empty())
teamQ.push(team);
Q[team].push(a);
}
else
{
int team = teamQ.front();
cout << Q[team].front() << endl;
Q[team].pop();
if (Q[team].empty())
teamQ.pop();
}
}
cout << endl;
}
}

解析&吐槽:

这道题用 stl 的 queue 就可以解。题目的意思大概是很多人排队,但是每个人都属于某一个组织,新加入的人如果在队列中有 同组织的人,就插队到同组织的最后一个人的后面。如果没有,则排在整个队列的最后。出队的方式和普通队列一样,从前面走。 题目还贴心地提醒我们:如果出队和入队的复杂度不是 O(1)的话,就很可能会超时。

我的思路是先给组织排一个队列,然后每个组织有一个单独的队列来表示在内部的每个人是怎么排队的。我使用一个 vector 来保存 每个组织单独的队列,如果队列为空,则说明这个组织没有人在排队,然后就可以让新来的人进入组织的队列,然后把组织的编号 放入整体的队列。如果队列不为空,就直接把人放到组织的队列的末尾。在出队时,只是检测队列开头的组织的编号,然后把 vector 中的相应组织的队列弹出一个人;如果在弹出之后队列变成了空的,就在总体队列中把组织的编号弹出。由此,每一个 操作的时间复杂度都是 O(1)了。

本作品采用 署名-相同方式共享 4.0 国际 进行许可。欢迎转载、使用、重新发布,但务必保留文章署名 “不科学的科学君” (Liu233w) 与博客链接: https://liu233w.github.io ,基于本文修改后的作品务必以相同的许可发布。如有任何疑问,请 与我联系

加载评论框需要翻墙